CIPTV2 – Lab Update Part 2

So moving into the LAN… Starting with HQ…

I have setup all required VLANs on the HQ router as follows: (Router on a stick approach)

interface FastEthernet0/0
 description HQ to HQ_SWITCH
 no ip address
 duplex auto
 speed auto
 !
 interface FastEthernet0/0.1
 description HQ_VOICE_VLAN
 encapsulation dot1Q 110
 ip address 10.1.110.1 255.255.255.0
 !
 interface FastEthernet0/0.2
 description HQ_DATA_VLAN
 encapsulation dot1Q 10
 ip address 10.1.10.1 255.255.255.0
 !
 interface FastEthernet0/0.3
 description HQ_SERVERS_VLAN
 encapsulation dot1Q 5
 ip address 10.1.5.1 255.255.255.0

Downstream on the HQ switch…

Ports for the HQ phones:

interface FastEthernet0/1
 description HQ_VOICE_VLAN_110
 switchport mode access
 switchport voice vlan 110
 spanning-tree portfast
 !
 interface FastEthernet0/2
 description HQ_VOICE_VLAN_110
 switchport mode access
 switchport voice vlan 110
 spanning-tree portfast

I have also setup a DHCP pool for the phones directly on the HQ_SWITCH which is working a treat! **I excluded any static addresses from assignment

ip dhcp excluded-address 10.1.110.1
 ip dhcp excluded-address 10.1.110.2
 !
 ip dhcp pool HQ_PHONES
 network 10.1.110.0 255.255.255.0
 default-router 10.1.110.1
 option 150 ip 10.1.5.16

The phones are picking up the IPs all OK, but of course at this stage can’t contact either CUCM box.

Trunk into ESXi:

interface FastEthernet0/9
 description HQ_SWITCH_TO_ESXI
 switchport trunk encapsulation dot1q
 switchport mode trunk

**Only 1 physical NIC is required on the switch to ESXi. I have setup Virtual Switches within ESXi and enabled the VLAN tag for each VLAN back to the switch. You just need to assign each server to the appropriate network switch. This is something I have never done before, but got there in the end! 🙂

I have also setup my management access to ESXi from my desktop PC:

interface FastEthernet0/11
 description ESXi MGMT
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
 !
 interface FastEthernet0/12
 description PC MGMT
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast

This enables me to connect using the vSphere client from my desktop PC.

Trunk between HQ router and switch:

interface FastEthernet0/24
 description HO_SWITCH TO HQ ROUTER
 switchport trunk encapsulation dot1q
 switchport mode trunk

Fairly straight forward R&S concepts.

So at this stage HQ has all VLANs as per the topology.

As we speak now I am building my publisher and subscriber for HQ. (This takes ages!!) I have also built a Windows Server 2003 DC and also a Windows XP client. On the DC I setup the DNS service and setup A records for all my servers. All Virtual Machines have been assigned to their appropriate VLANs and it looks like everyone can ping everyone else!

So now the waiting game for the CUCM builds and then also the R&S configuration of BB which will use physical resources in HQ… This is going to take some time!

 

 

Advertisements